It is currently Tue Feb 18, 2020 5:11 pm
Board index » Talking About Stuff » N00b Talk



Post new topic Reply to topic  [ 4 posts ] 
Author Message

Offline
newbie
User avatar

Joined: Wed Nov 13, 2019 6:14 pm
Posts: 4
Location: Hills
Vehicle: 95 Vit JLX LWB 1.6

Post Posted: Sat Feb 15, 2020 1:56 pm 
Reply with quote Top  
Had my front badge fall off my vit about a month ago. Past owner seemed to have just glued the badge back on as the pins that I assume hold it in place had broken off. Looking for some recommendations to pop it back on and hopefully keep it on this time! cheers

 Profile  

Offline
I live here!
I live here!
User avatar

Joined: Sun Jul 05, 2009 12:00 am
Posts: 43706
Location: Rockingham W.A
Vehicle: SQ625

Post Posted: Sat Feb 15, 2020 2:53 pm 
Reply with quote Top  
Badges are uselly held on with double sided tape

_________________
Joe likes boobs ( . )( . ) ( ° )( ° )

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Sat Oct 06, 2012 6:19 pm
Posts: 1864
Vehicle: Sierras!! SWB and LWB

Post Posted: Mon Feb 17, 2020 12:21 pm 
Reply with quote Top  
there is also a ‘badge adhesive’ available, 3M 03601 or similar

 Profile  

Offline
newbie
User avatar

Joined: Wed Nov 13, 2019 6:14 pm
Posts: 4
Location: Hills
Vehicle: 95 Vit JLX LWB 1.6

Post Posted: Mon Feb 17, 2020 7:10 pm 
Reply with quote Top  
Just ended up using some strong double sided tape. Cheers!

 Profile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

Jump to:  


Who is online

Users browsing this forum: atari4x4, zukebob and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
Untitled Document


Untitled Document


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group :: Style based on FI Subice by phpBBservice.nl :: All times are UTC + 10 hours