It is currently Tue Feb 18, 2020 4:36 pm
Board index » Talking About Stuff » Suzuki Talk



Post new topic Reply to topic  [ 17 posts ] 
Author Message

Offline
az supporter
az supporter
User avatar

Joined: Fri Nov 27, 2009 11:00 pm
Posts: 3426
Location: imbil/gympie. qld
Vehicle: 03 Jimny

Post Posted: Sat Sep 24, 2011 11:51 pm 
Reply with quote Top  
hey guys, when i first got my jimny i thought it had done a head or gasket.
it seems to be fine now, but now it has been draining the coolant out of the radiator and into the overflow bottle.
i had the bottle toped up to the full mark, now its full to the lid.
and radiator coolant level has dropped below the fins.
doesnt over heat either
im stumped, whats the go there :?

much appreciated

_________________
03 Jimny 30 km2s 75mm lift f&r locked winch


Last edited by zooky08 on Sun Sep 25, 2011 12:01 am, edited 1 time in total.
 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Wed Aug 02, 2006 12:00 am
Posts: 3459
Location: licking some windows
Vehicle: LJ20 LJ50

Post Posted: Sun Sep 25, 2011 12:01 am 
Reply with quote Top  
You have the wrong cap on the radiator.

You need a recovery cap not a standard cap. If it says recovery cap on the one you have its stuffed so get a new one and it will be fine.

The water expands in the radiator and goes into the overflow bottle. then as it cools it is supposed to be sucked back in. If your cap is stuffed or is not a recovery one it will just suck air in instead resulting in a empty looking radiator.

_________________
Camels have nice toes

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Fri Nov 27, 2009 11:00 pm
Posts: 3426
Location: imbil/gympie. qld
Vehicle: 03 Jimny

Post Posted: Sun Sep 25, 2011 12:04 am 
Reply with quote Top  
its just the stand radiator cap i would imagine
deffently doesnt suck it back in

_________________
03 Jimny 30 km2s 75mm lift f&r locked winch

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Sat May 23, 2009 12:00 am
Posts: 21335
Location: Smart Ass Island

Post Posted: Sun Sep 25, 2011 12:17 am 
Reply with quote Top  
Does it over heat on the h/way? or with the a/c on??

Could be the clutch fan....... but a cap is allot cheaper & replacing it eliminates that...

_________________
I used to be indecisive,
now I'm not so sure.....

 Profile  

Offline
User avatar

Joined: Wed Dec 08, 2010 7:46 am
Posts: 941
Location: Shidoni!

Post Posted: Sun Sep 25, 2011 12:43 am 
Reply with quote Top  
I'd be double checking the Pressure Rating on that cap vs. the cooling system pressure rating ( should be on a sticker on the under side of your Bonnet ) or someone on here might know what it is...

_________________
Stocker

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Fri Nov 27, 2009 11:00 pm
Posts: 3426
Location: imbil/gympie. qld
Vehicle: 03 Jimny

Post Posted: Sun Sep 25, 2011 12:51 am 
Reply with quote Top  
I havnt tested for the pressure but the radiator holds pressure pretty good. Radiator hose is pretty firm. When taking the cap of you can here the pressure.

Doesn't over heat at all. What I did notice the other day was my aircon pipe was boiling hot(burnt myself). Should it be hot?

_________________
03 Jimny 30 km2s 75mm lift f&r locked winch


Last edited by zooky08 on Sun Sep 25, 2011 1:03 am, edited 1 time in total.
 Profile  

Offline
I live here!
I live here!
User avatar

Joined: Tue Jan 29, 2008 11:00 pm
Posts: 10525
Location: Brissie
Vehicle: Popemobile

Post Posted: Sun Sep 25, 2011 12:54 am 
Reply with quote Top  
One will be hot, one will be cold. Does it blow cold inside?

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Sat May 23, 2009 12:00 am
Posts: 21335
Location: Smart Ass Island

Post Posted: Sun Sep 25, 2011 12:55 am 
Reply with quote Top  
Scrawn wrote:
One will be warm, one will be cold. Does it blow cold inside?


:roll:

see if the lil elec fan on the front of the rad's working.....

_________________
I used to be indecisive,
now I'm not so sure.....

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Fri Nov 27, 2009 11:00 pm
Posts: 3426
Location: imbil/gympie. qld
Vehicle: 03 Jimny

Post Posted: Sun Sep 25, 2011 1:10 am 
Reply with quote Top  
One is hot one I could freeze my beer with :D. Nice aircom in car.
Electric fan kicks in when you press the zircon button

I tipped the overflow bottle back into the radiator to top it back up and the coolant level when back down to the full mark on the bottle.
So it's not using water. It's just going into the bottle until no more can go in.
So new recovery cap like tzar said?

_________________
03 Jimny 30 km2s 75mm lift f&r locked winch

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Sat May 23, 2009 12:00 am
Posts: 21335
Location: Smart Ass Island

Post Posted: Sun Sep 25, 2011 1:34 am 
Reply with quote Top  
zooky08 wrote:
One is hot one I could freeze my beer with :D. Nice aircom in car.
Electric fan kicks in when you press the zircon button

I tipped the overflow bottle back into the radiator to top it back up and the coolant level when back down to the full mark on the bottle.
So it's not using water. It's just going into the bottle until no more can go in.
So new recovery cap like tzar said?


Yep!!!

_________________
I used to be indecisive,
now I'm not so sure.....

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Sat May 23, 2009 12:00 am
Posts: 21335
Location: Smart Ass Island

Post Posted: Sun Sep 25, 2011 1:34 am 
Reply with quote Top  
Are both top & bottom hoses hot at operating temp??

_________________
I used to be indecisive,
now I'm not so sure.....

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Fri Nov 27, 2009 11:00 pm
Posts: 3426
Location: imbil/gympie. qld
Vehicle: 03 Jimny

Post Posted: Sun Sep 25, 2011 2:25 am 
Reply with quote Top  
steak_knife wrote:
Are both top & bottom hoses hot at operating temp??
Yep both hot but top one is more hot then bottom

_________________
03 Jimny 30 km2s 75mm lift f&r locked winch

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Thu May 28, 2009 12:00 am
Posts: 556
Location: Newcastle

Post Posted: Thu Oct 20, 2011 4:09 am 
Reply with quote Top  
Hey zooky08, have you sorted this issue out yet mate.
Mines doing the same thing but every now and then it actually spy's out the overflow bottle.
I've tried new caps, different thermostats, tested the pressure in the radiator several times, replaced me hoses but still every now and then it does this shit.
Bloody frustrating...

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Fri Nov 27, 2009 11:00 pm
Posts: 3426
Location: imbil/gympie. qld
Vehicle: 03 Jimny

Post Posted: Thu Oct 20, 2011 4:39 am 
Reply with quote Top  
Nah mate sorry my Jim been up on jack stand for the last 3 weeks so I havnt really looked into it.
Hopefully a new cap fixes mine.

_________________
03 Jimny 30 km2s 75mm lift f&r locked winch

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Thu May 28, 2009 12:00 am
Posts: 556
Location: Newcastle

Post Posted: Thu Oct 20, 2011 5:02 am 
Reply with quote Top  
Bugger!!!!!
I've had me head tested & just about to check for canon dioxide again coz I've got tiny bubbles
surfacing on the top of me radiator, but I had them last time.
considering this engine has only done 35000 since rebuild and this me 2nd head gasket.
I'm suspecting either me water pump or me top chamber.

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Wed Jul 16, 2008 12:00 am
Posts: 8199
Location: Melbourne
Vehicle: Pajero 97 NL 3,5 LWB

Post Posted: Thu Oct 20, 2011 5:25 am 
Reply with quote Top  
Sometimes minute cracks can form in the over flow hose,
the bottle, and or the brass fitting on the radiator.
So it sux air instead of water.
Also bottle needs a breather hole,
so air can get back in, when water gets sucked out.

_________________
VIC ZOOK CLUB
http://www.vic.suzuki4wd.com/forum/

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Fri Nov 27, 2009 11:00 pm
Posts: 3426
Location: imbil/gympie. qld
Vehicle: 03 Jimny

Post Posted: Thu Oct 20, 2011 5:31 am 
Reply with quote Top  
I did have bubbles as well a while ago but they seem to be gone now

_________________
03 Jimny 30 km2s 75mm lift f&r locked winch

 Profile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ] 

Jump to:  


Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot] and 6 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
Untitled Document


Untitled Document


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group :: Style based on FI Subice by phpBBservice.nl :: All times are UTC + 10 hours